Webhook Delivery Delays

Incident Report for WorkOS

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 17:12 EDT

Update

This has been resolved.
Posted Jul 27, 2026 - 17:11 EDT

Monitoring

We have confirmed that webhook delivery times are back to normal levels. We are continuing to monitor.
Posted Jul 27, 2026 - 16:54 EDT

Update

We have rolled out a fix and are seeing improvements to webhook delivery times. We will provide another update soon.
Posted Jul 27, 2026 - 16:34 EDT

Identified

We have identified the cause of the delays in webhook delivery and are rolling out a fix to reduce processing latency.
Posted Jul 27, 2026 - 15:36 EDT

Investigating

We're investigating delays in webhook delivery. We will share an update as soon as possible.
Posted Jul 27, 2026 - 15:09 EDT