Sending duplicate update webhooks for users and groups
Incident Report for WorkOS
Resolved
This incident has been resolved.
Posted Mar 30, 2023 - 00:30 EDT
Monitoring
We've deployed a fix and are monitoring the situation.
Posted Mar 29, 2023 - 22:11 EDT
Identified
We've noticed a bug in our system that could send a large amount of duplicate `dsync.user.updated` and `dsync.group.updated` webhooks. These updates may put additional strain on your systems processing these webhooks, but should not impact your directory state. We apologize for the inconvenience and are currently deploying a fix.
Posted Mar 29, 2023 - 21:25 EDT