SSO API Latency Degradation Caused by Transient Capacity Constraints

Incident Report for WorkOS

Resolved

The issue has been resolved, and SSO login performance has returned to normal. We will continue to monitor closely to ensure stability.
Posted Apr 20, 2026 - 15:17 EDT

Identified

Between 14:40 and 14:53 UTC, SSO endpoints experienced increased latency and intermittent timeouts. The issue was caused by a temporary reduction in available capacity due to an underlying infrastructure event, which led to a brief period of degraded performance
Posted Apr 20, 2026 - 15:16 EDT
This incident affected: Core Services (SSO, AuthKit).