Continued email delivery errors

Incident Report for WorkOS

Resolved

Email delivery is operating normally.
Posted Jul 27, 2026 - 13:37 EDT

Monitoring

We have remediated the issue. Email delivery rates have recovered and reported email delivery status in Dashboard are being updated properly. We are continuing to monitor.
Posted Jul 27, 2026 - 11:36 EDT

Update

We are continuing to investigate email delivery errors in addition to Dashboard email delivery statuses not being updated.
Posted Jul 27, 2026 - 10:33 EDT

Investigating

We are investigating reports that email delivery statuses in Dashboard are not being updated.
Posted Jul 27, 2026 - 10:10 EDT
This incident affected: Supporting Services (Dashboard).