Increased webhook delivery delay

Incident Report for WorkOS

Resolved

We've resolved the internal telemetry issue.
Posted Oct 14, 2025 - 07:52 EDT

Monitoring

We've confirmed that webhook delivery has been and continues to process successfully. We are resolving an internal telemetry issue and will continue to monitor.
Posted Oct 14, 2025 - 07:22 EDT

Investigating

Webhook delivery across services are currently delayed. We will share an update once we have more information.
Posted Oct 14, 2025 - 06:24 EDT