Audit logs failing to load on Admin Portal

Incident Report for WorkOS

Resolved

This incident has been resolved.
Posted May 13, 2025 - 13:15 EDT

Monitoring

A fix is deployed. Continuing to monitor.
Posted May 13, 2025 - 12:46 EDT

Investigating

We are currently investigating an issue with our Admin Portal that is affecting only the Audit Logs product.

We will share more information as soon as it's available.
Posted May 13, 2025 - 10:50 EDT
This incident affected: Supporting Services (Admin Portal) and Core Services (Audit Logs).