Elevated errors during email delivery

Incident Report for WorkOS

Resolved

Delivery rates have recovered.
Posted Jul 27, 2026 - 09:04 EDT

Monitoring

We have applied a refined mitigation and are continuing to monitor delivery rates.
Posted Jul 27, 2026 - 08:11 EDT

Investigating

Our mitigation did not fully resolve the issue. We are continuing to investigate.
Posted Jul 27, 2026 - 07:20 EDT

Monitoring

We have implemented a mitigation and are continuing to monitor.
Posted Jul 27, 2026 - 07:03 EDT

Investigating

We are investigating elevated errors during delivery of emails.
Posted Jul 27, 2026 - 06:05 EDT