Static asset delivery failures

Incident Report for WorkOS

Resolved

Static assets delivery rates have recovered.
Posted Sep 02, 2026 - 15:06 EDT

Monitoring

We have mitigated the issue and are continuing to monitor.
Posted Sep 02, 2026 - 14:33 EDT

Identified

We have identified increased failures delivering static assets to end users with strict network allowlists. A fix is in progress.
Posted Sep 02, 2026 - 12:39 EDT
This incident affected: Core Services (AuthKit).