Dashboard unavailable
Incident Report for WorkOS
Resolved
The fix has been deployed and the Dashboard should be working as expected.
Posted Mar 15, 2024 - 15:33 EDT
Identified
Dashboard is unavailable. We have identified the issue and are rolling out a fix.

We will share an update as soon as possible.
Posted Mar 15, 2024 - 15:08 EDT
This incident affected: Supporting Services (Dashboard).