Elevated Dashboard Errors

Incident Report for WorkOS

Resolved

The issue has been resolved. The WorkOS Dashboard is fully operational.
Posted May 01, 2026 - 16:51 EDT

Monitoring

We've identified and addressed the issue. We'll continue to monitor.
Posted May 01, 2026 - 16:40 EDT

Investigating

We are investigating an issue with our Dashboard.

We will share an update as soon as possible.
Posted May 01, 2026 - 16:28 EDT
This incident affected: Supporting Services (Dashboard).