Email Delivery Delayed

Incident Report for WorkOS

Resolved

This issue is resolved.
Posted Jul 24, 2025 - 19:38 EDT

Monitoring

Our team has implemented a fix and we are seeing email delivery recovery. We'll continue to monitor for issues.
Posted Jul 24, 2025 - 19:35 EDT

Identified

Our team has identified the issue and is implementing a fix.
Posted Jul 24, 2025 - 19:25 EDT

Investigating

We've received reports that email delivery from our platform is delayed. Our team is currently investigating.
Posted Jul 24, 2025 - 18:11 EDT
This incident affected: Supporting Services (Dashboard, Admin Portal) and Core Services (AuthKit).