Email delivery delays

Incident Report for WorkOS

Resolved

We've resolved the issue with email delivery delays.
Posted Jul 16, 2026 - 08:21 EDT

Identified

We've identified the issue causing email delays. We are working to mitigate the issue.
Posted Jul 16, 2026 - 08:18 EDT

Investigating

We're seeing delays in email delivery. Our team is investigating. We will share an update as soon as possible.
Posted Jul 16, 2026 - 08:06 EDT
This incident affected: Supporting Services (Dashboard) and Core Services (AuthKit).