Elevated Webhook Latency

Incident Report for WorkOS

Resolved

This has been resolved.
Posted May 12, 2026 - 14:41 EDT

Monitoring

Our team is seeing webhook delivery recover and we are continuing to monitor the situation.
Posted May 12, 2026 - 14:21 EDT

Identified

Our team has identified the issue and is implementing mitigations.
Posted May 12, 2026 - 14:04 EDT

Investigating

We are seeing delays delivering webhooks. Our team is currently investigating.
Posted May 12, 2026 - 13:59 EDT