Elevated API Errors

Incident Report for WorkOS

Postmortem

We’ve published a post-mortem on the October 20 service disruption to our blog, detailing what happened and how we’re strengthening the resiliency of all WorkOS products.

Posted Oct 24, 2025 - 15:48 EDT

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 06:06 EDT

Monitoring

Services are recovering with significant improvement. Our team continues to monitor the situation with our upstream provider.
Posted Oct 20, 2025 - 05:38 EDT

Update

We continue to be impacted by the AWS incident. Engineers are currently investigating options for restoring service despite the AWS incident.

We will share an update as soon as possible.
Posted Oct 20, 2025 - 04:58 EDT

Update

We are aware that one of our upstream providers is experiencing issues. We are continuing to investigate.
Posted Oct 20, 2025 - 03:43 EDT

Update

We are seeing elevated error rates across our services.

We will share an update as soon as possible.
Posted Oct 20, 2025 - 03:35 EDT

Investigating

We are investigating an issue with our API.

We apologize for the inconvenience and will share an update once we have more information.
Posted Oct 20, 2025 - 03:17 EDT
This incident affected: Supporting Services (Dashboard, Admin Portal) and Core Services (SSO, Directory Sync, Audit Logs, AuthKit).