Elevated Events API Errors

Incident Report for WorkOS

Resolved

The issue affecting the Events API GET /events endpoint has been resolved. The fix has been deployed, and affected requests are now processing normally.
Posted May 28, 2026 - 22:46 EDT

Identified

We have identified the cause of the elevated errors affecting the GET /events API and are working on a resolution. We’ll share another update soon.
Posted May 28, 2026 - 22:30 EDT
This incident affected: Core Services (Directory Sync).