Email Delivery Delays

Incident Report for WorkOS

Resolved

This has been resolved.
Posted Jul 21, 2026 - 22:51 EDT

Monitoring

We've remediated the issue and are seeing email delivery recover.
Posted Jul 21, 2026 - 22:19 EDT

Identified

We've identified the issue and are implementing remediations.
Posted Jul 21, 2026 - 22:16 EDT

Investigating

We're investigating possible email delivery delays.
Posted Jul 21, 2026 - 21:35 EDT