Delayed Email Deliverability

Incident Report for WorkOS

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 15:54 EDT

Monitoring

We have remediated the issue. Email delivery rates have recovered and reported email delivery status in Dashboard are being updated properly. We are continuing to monitor.
Posted Jul 29, 2026 - 15:24 EDT

Identified

We've identified the issue and have implemented a mitigation. We are seeing normal email deliverability now but Dashboard email delivery statuses are currently not being updated.
Posted Jul 29, 2026 - 14:36 EDT

Investigating

We're investigating delays in email deliverability.
Posted Jul 29, 2026 - 14:30 EDT
This incident affected: Core Services (AuthKit).