Organization deletions delayed
Incident Report for WorkOS
Resolved
Operations have returned to normal.
Posted Jan 31, 2023 - 19:33 EST
Monitoring
We've deployed a fix and the delayed organization deletions have been processed.

We are continuing to monitor the situation.
Posted Jan 31, 2023 - 19:00 EST
Identified
We've identified the issue and are working on a resolution.
Posted Jan 31, 2023 - 16:24 EST
Investigating
We've observed some delays when deleting organizations and are currently investigating.
Posted Jan 31, 2023 - 16:22 EST