Elevated API Errors

Incident Report for WorkOS

Resolved

From 13:35 UTC to 14:24 UTC users connecting through our Chicago (ORD) edge node may have experienced elevated API error rates. We have resolved the issue and are monitoring.
Posted Jun 22, 2026 - 14:01 EDT

Monitoring

We detected elevated errors from our Chicago (ORD) edge node. Errors have since recovered and we're continuing to monitor.
Posted Jun 22, 2026 - 10:42 EDT

Investigating

We are investigating elevated error rates across our API.

We apologize for the inconvenience and will share an update once we have more information.
Posted Jun 22, 2026 - 10:03 EDT