Webhook Delivery Delays

Incident Report for WorkOS

Resolved

All backlogged webhooks are delivered. This incident has been resolved.
Posted Apr 10, 2025 - 16:59 EDT

Update

We’ve identified the issue and are seeing improvements in webhook delivery. Some delays may still occur as we continue to monitor and work toward full resolution.
Posted Apr 10, 2025 - 15:32 EDT

Identified

We’ve identified the issue and are seeing improvements in webhook delivery latency. We’re continuing to monitor to delivery.
Posted Apr 10, 2025 - 14:03 EDT

Investigating

We’re currently investigating an issue causing delays in webhook delivery.
Posted Apr 10, 2025 - 13:32 EDT
This incident affected: Core Services (Directory Sync).