Elevated Authkit SSO Errors

Incident Report for WorkOS

Resolved

The issue has been resolved.
Posted Jul 31, 2026 - 14:06 EDT

Monitoring

The fix has deployed, we are monitoring systems to verify the impact is fully mitigated
Posted Jul 31, 2026 - 13:10 EDT

Update

We have identified the issue and are deploying a fix. AuthKit SSO sign-on remains partially degraded for a small subset of customers; standalone SSO continues to be unaffected. We'll share another update once the fix has fully rolled out.
Posted Jul 31, 2026 - 13:00 EDT

Update

The issue affects a small set of customers using Authkit SSO. The standalone SSO API remains unaffected, we have corrected that here on the status page
Posted Jul 31, 2026 - 12:34 EDT

Update

We have identifed an issue causing a small subset of Authkit SSO customers to experience errors during sign-on. A fix is being prepared.
Posted Jul 31, 2026 - 12:16 EDT

Update

It appears some users may be experiencing a redirect loop during sign-on, we are narrowing in on a cause
Posted Jul 31, 2026 - 12:12 EDT

Investigating

We're investigating an increase in Single Sign-On errors. We will share an update as soon as possible.
Posted Jul 31, 2026 - 12:01 EDT
This incident affected: Core Services (SSO, AuthKit).