Email Delivery Delays

Incident Report for WorkOS

Resolved

This has been resolved.
Posted Apr 29, 2026 - 22:23 EDT

Monitoring

Email delivery is returning to normal. Our team is continuing to monitor.
Posted Apr 29, 2026 - 21:56 EDT

Identified

Our team has identified the issue and is actively working on mitigations to restore email delivery for the affected subset of users.
Posted Apr 29, 2026 - 21:30 EDT

Investigating

We’re seeing email delivery delays affecting some users. Our team is investigating.
Posted Apr 29, 2026 - 21:00 EDT
This incident affected: Core Services (AuthKit).