Increased Webhook Delays

Incident Report for WorkOS

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 17:44 EDT

Monitoring

Delays on directory sync webhooks have returned to baseline levels, we are continuing to monitor.
Posted Sep 18, 2025 - 17:32 EDT

Identified

Webhook delivery for Directory Sync events is currently delayed. We are currently working through the backlog of messages, and working on increasing throughput.
Posted Sep 18, 2025 - 15:33 EDT
This incident affected: Core Services (Directory Sync).