Elevated Webhook Latency

Incident Report for WorkOS

Resolved

Webhook latency is back to normal levels. We have identified that this latency only affected a very small subset of customers.
Posted Jul 21, 2026 - 15:49 EDT

Monitoring

We're seeing a return to normal webhook latency and are continuing to monitor.
Posted Jul 21, 2026 - 15:37 EDT

Identified

We've identified the source of the latency and have implemented a fix.
Posted Jul 21, 2026 - 15:09 EDT

Investigating

We're investigating webhook delivery delays.

We apologize for the inconvenience and will share an update once we have more information.
Posted Jul 21, 2026 - 14:58 EDT